Benvenuto!

Questo è il forum ufficiale dell'Associazione Odoo Italia. Dopo esserti registrato potrai partecipare ponendo domande o rispondendo a quelle esistenti. Non scordarti di compilare il tuo profilo e consultare le linee guida prima di iniziare a scrivere.

0

0
PG
Il 12/02/20, 14:07

Ancora niente, ho provato:

1. HO rimosso la versione di wk (che cmq era l'ultima)

2. Installata la versione suggerita da Sergio (wget https://github.com/wkhtmltopdf/wkhtmltopdf/releases/download/0.12.5/wkhtmltox-0.12.5-1.centos7.x86_64.rpm&& sudo yum localinstall wkhtmltox-0.12.5-1.centos7.x86_64.rpm)
3. Inseriti i parametri di sistema:

    - web.base.url : http://127.0.0.1:8069 oppure tutti 0 e la porta oppure localhost e porta

    - report.url : http://127.0.0.1:8069 oppure tutti 0 e la porta oppure localhost e porta

    - web.base.ur.freeze : True


La tua risposta


0
Sergio Zanchetta
Il 12/02/20, 09:10

Potrebbe essere un problema di versione di wkhtmltopdf installata.

https://github.com/odoo/odoo/wiki/Wkhtmltopdf

Che ti porta all'ultima versione che trovi qui, usa quella specifica per la distribuzione che usi.

https://github.com/wkhtmltopdf/wkhtmltopdf/releases


La tua risposta


0
Gianmarco Conte
Il 06/02/20, 11:55

Ciao, se non erro ebbi lo stesso problema su un report, prova ad aggiungere la call ad un layout dopo il <template id='template_ecc">

<t t-call="web.internal_layout">




La tua risposta

0
PG
Il 10/02/20, 11:32

Si già lo faccio, con external_layout, infatti, come dicevo in descrizione in html è tutto ok. Credo sia un problema legato a wkhtmltopdf


La tua risposta

Resta informato

Informazioni sulla comunità

Forum ufficiale dell'Associazione Odoo Italia Leggi le linee guida

Strumenti di richiesta

44 follower

Statistiche

Richiesta del: 05/02/20, 11:58
Vista: 834 volte
Ultimo aggiornamento: 12/02/20, 14:07